Recibir un error al intentar ejecutar comandos añadir la migración en la consola del gestor de paquetes

votos
32

Necesito otro par de ojos para mirar esto. El siguiente código se ejecuta en el estudio visual y cuando está inactivo la barra lateral verde indica que la sintaxis es correcta.

Sin embargo cuando corro una migración complemento en la consola de administrador de paquetes que responde con el siguiente error.

Objeto no válido pasó en, ':' o '}' espera (817).

Parece tener problema con mi aplicación dependencia, pero no puedo encontrar ningún ejemplo de un soporte o una coma que falta.

Si usted lo puede encontrar con mucho gusto proporcionar su respuesta con un voto. ¡Gracias!

{
  buildOptions: {
    emitEntryPoint: true,
    preserveCompilationContext: true
  },
  dependencies: {
    Microsoft.NETCore.App: {
      version: 1.0.1,
      type: platform
    },
    Microsoft.AspNetCore.Diagnostics: 1.0.0,
    Microsoft.Extensions.Configuration.FileExtensions: 1.0.0,
    Microsoft.AspNetCore.Server.IISIntegration: 1.0.0,
    Microsoft.AspNetCore.Server.Kestrel: 1.0.1,
    Microsoft.Extensions.Logging.Console: 1.0.0,
    Microsoft.Extensions.Configuration.Json: 1.0.0,
    Microsoft.AspNetCore.StaticFiles: 1.0.0,
    Microsoft.AspNetCore.Mvc: 1.0.0,
    Microsoft.EntityFrameworkCore.SqlServer: 1.1.0,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final,
    Microsoft.AspNetCore.Identity: 1.0.0 //New package required for added functionality
  },
  frameworks: {
    netcoreapp1.0: {
      imports: [
        dotnet5.6,
        portable-net45+win8
      ]
    }
  },
  publishOptions: {
    include: [
      wwwroot,
      web.config
    ]
  },
  runtimeOptions: {
    configProperties: {
      System.GC.Server: true
    }
  },
  scripts: {
    postpublish: [ dotnet publish-iis --publish-folder %publish:OutputPath% --framework %publish:FullTargetFramework% ]
  },
  tools: {
    Microsoft.AspNetCore.Server.IISIntegration.Tools: 1.0.0-preview2-final,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final
  }
}
Publicado el 22/11/2016 a las 14:49
por usuario
En otros idiomas...                            


1 respuestas

votos
6

El único problema que detecto en su JSON es el comentario que tenemos aquí

//New package required for added functionality

Los comentarios no son válidos en una estructura JSON así que probablemente error está relacionado con eso.

Respondida el 22/11/2016 a las 14:54
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more